Mastermind GT Firmware / Editor 4.9.1

rjmmusic

Administrator
Staff member
Firmware and editor 4.9.0 are now available! (Now updated to 4.9.1, see below)

FEATURES:
  • New device support:
    • Red Panda Bitmap 2 and Raster 2
    • Strymon V2 pedals: Bluesky, Deco, Dig, El Capistan, Flint, Lex
    • Wampler Metaverse
  • Added Condensed Fonts setting, which makes all button displays use the condensed (narrower) font all the time
  • Added Dynamic Distortion block support in Axe-Fx III
  • Fixed editor bug that caused clicks on IA buttons in the Presets tab to register in the wrong page
  • Fixed an editor bug in the PC messages section that can cause PCs to be sent when they aren't supposed to
CHANGES IN 4.9.1:
  • A proposed fix to a problem that caused the editor to hang during settings transfers on Macs. Let's hope this works!
  • Fixed the inability to select a few Axe-Fx III CCs at the end of the CC list
  • Fixed Preset Number button menu on GT/10
  • Fixed Set IA and IA Link problems on IA Cycle Menu buttons
  • Fix bug that prevented Song action from updating preset button names
TO UPDATE FIRMWARE:

PLEASE DON'T DO A MAJOR FIRMWARE UPDATE RIGHT BEFORE YOUR BIG GIG!

- First, back up your settings to a flash drive or computer! If you go back to 4.7 or earlier, your GT will factory reset.
- Download and unzip the firmware file.
- Copy the file to a USB flash drive, and remove any other .rjf files from the flash drive.
- Eject the drive from your computer.
- Power on the Mastermind GT while holding the two buttons under the main screen.
- Keep holding until you see "Mastermind GT Bootloader" appear on the screen.
- Now plug the flash drive into your GT. The update should begin and will take a few minutes to complete.

Firmware: https://www.rjmmusic.com/downloads/MMGT/MMGT491.zip

Mac Editor: https://www.rjmmusic.com/downloads/MMGT/MMGTEditor-4.9.1.dmg
PC Editor: https://www.rjmmusic.com/downloads/MMGT/MMGTEditor-4.9.1.zip

Manual: https://www.rjmmusic.com/downloads/MMGT/Mastermind GT Manual-4.3.pdf
 
Last edited:

is9582

Well-Known Member
Firmware and editor 4.9.0 are now available!

FEATURES:
  • New device support:
    • Red Panda Bitmap 2 and Raster 2
    • Strymon V2 pedals: Bluesky, Deco, Dig, El Capistan, Flint, Lex
    • Wampler Metaverse
  • Added Condensed Fonts setting, which makes all button displays use the condensed (narrower) font all the time
  • Added Dynamic Distortion block support in Axe-Fx III
  • Fixed editor bug that caused clicks on IA buttons in the Presets tab to register in the wrong page
  • Fixed an editor bug in the PC messages section that can cause PCs to be sent when they aren't supposed to
Nice work Ron!
Cheers
Lee
 

HereToday

Member
Hi Ron,

Not sure if its a bug or something I'm doing, but I seem to be getting a PC message broadcast on all channels. Here are the conditions that initiate it:

- The GT-22 has to be connected to the Axe-Fx III.
- The broadcast only happens when loading Axe patches numbering in the 30 to 60 range.
- The PC broadcast corresponds to the Axe patch # being loaded.
- Does not matter how the Axe patch is loaded (GT22 bank up/down, Fractal foot controller or Axe-Edit).

I have searched high and low for a rogue button or setting, but so far I have come up empty. Unfortunately, I can't tell you for absolute certain if this behavior started with 4.9. It is possible that it went unobserved earlier. I caught it last night since I connected my RV500 & DD-500 and it started tripping unintended preset changes on those pedals.

Happy to post my settings file if you think that will help you. In the meantime, I will keep searching for something I may have done wrong.

Also, love the new fonts!!
 

HereToday

Member
FYI, diagram of signal and midi chain also attached.
 

Attachments

  • Signal Chain & MIDI Control Layout 4Jul2022.pdf
    197.8 KB · Views: 1

rjmmusic

Administrator
Staff member
If you look in the Presets tab, presets 32 and above are programmed to send PCs to every device. Compare the PC Messages section for preset 31 and preset 32. Preset 32 has every device's PC box checked and preset 31 does not. That's the difference.

EDIT: If you want a fast way to clear out those PC messages, go to the Devices tab, select a device, then click Set Preset PCs to None. That will clear out all PC messages for all presets for that device.
 

is9582

Well-Known Member
Last night I was modifying my GT22 layouts, to include a couple buttons for the new Dynamic Distortion. I initially created this layout in 4.8.1, but was updating using the new 4.9.0 editor.
I noticed the newly added block type (AF3) behaved a bit different, when creating the action for a button, than previous block choices. Specifically, I was adding a Dynamic Distortion1 button, which is identified as CC#202, in the list of assignable items. I scrolled down near the bottom of the list, and clicked onto this item as usual, causing it to be highlighted, and then clicked the OK button. The field(s) (bottom right section, as well as in the action string in the bottom left) for the CC# did not change. I decided to move to another block-type in the list, and when I clicked the OK button, the associated CC# for that block-type was transferred to the proper field(s). I then went back and hard-keyed 202 into the CC# field in the bottom right. The string of data for this action also changed to the correct block-type in the lower left action field.
Anyone else experience this?

Cheers
Lee
 

rjmmusic

Administrator
Staff member
Last night I was modifying my GT22 layouts, to include a couple buttons for the new Dynamic Distortion. I initially created this layout in 4.8.1, but was updating using the new 4.9.0 editor.
I noticed the newly added block type (AF3) behaved a bit different, when creating the action for a button, than previous block choices. Specifically, I was adding a Dynamic Distortion1 button, which is identified as CC#202, in the list of assignable items. I scrolled down near the bottom of the list, and clicked onto this item as usual, causing it to be highlighted, and then clicked the OK button. The field(s) (bottom right section, as well as in the action string in the bottom left) for the CC# did not change. I decided to move to another block-type in the list, and when I clicked the OK button, the associated CC# for that block-type was transferred to the proper field(s). I then went back and hard-keyed 202 into the CC# field in the bottom right. The string of data for this action also changed to the correct block-type in the lower left action field.
Anyone else experience this?

Cheers
Lee
Fixed in 4.9.1
 

is9582

Well-Known Member
@rjmmusic
I finally had a chance to load 4.9.1 and the issue I experienced with assigning a button to Dynamic Distortion CC#202/203, is resolved. Cheers Ron!

Lee
 
@rjmmusic Last night during a gig I had an issue with my setlist presets jumping around. I'm using the Mastermind GT10 with an Axe Fx III, both on the latest firmware. All of my song presets are below number 40 but my Mastermind GT was selecting presets in the 100's. I power cycled twice but it still did not resolve the issue. This behavior has happened several times before with older firmware versions. I have not had this issue in a long time though and seems to have been reintroduced after I upgraded to firmware 4.9.1. Trying to upload my rjs file but I'm getting an error message that says the uploaded file is too large for the server. What can I do to ensure this issue doesn't happen again? Thanks!
 

rjmmusic

Administrator
Staff member
@rjmmusic Last night during a gig I had an issue with my setlist presets jumping around. I'm using the Mastermind GT10 with an Axe Fx III, both on the latest firmware. All of my song presets are below number 40 but my Mastermind GT was selecting presets in the 100's. I power cycled twice but it still did not resolve the issue. This behavior has happened several times before with older firmware versions. I have not had this issue in a long time though and seems to have been reintroduced after I upgraded to firmware 4.9.1. Trying to upload my rjs file but I'm getting an error message that says the uploaded file is too large for the server. What can I do to ensure this issue doesn't happen again? Thanks!
Typically, this is traced to a MIDI bank issue. One quick thing to check is that MIDI Receive Channel should be set to None in the GT's MIDI settings. If that's not it, please email your file to support@rjmmusic.com and I'll look at it.
 
Top