Axe-Fx II XL+ Tuner

cgscotto

Well-Known Member
Hi,
I followed the direction to get the Axe-Fx tuner to display on the Mastermind LT: IA button assigned CC action tuner on Axe-FX; System/Tuner added as second action; update on preset change checked; and bidirectional midi checked.

When I press the IA button, the tuner turns on on the Axe-Fx and I see >?< on the Mastermind screen. Plucking a string displays on the Axe-Fx, but the Mastermind LT does not change from >?<. What am I doing wrong?
 

rjmmusic

Administrator
Staff member
Make sure you have Send Realtime Sysex turned on in the Axe-Fx, and make sure your MIDI cable has all 5 pins wired thru.
 

cgscotto

Well-Known Member
I have a 7-pin midi cable with all pins wired, and it passes phantom power to the LT, so that is not the problem.

I had Send Realtime Sysex set to "All," which I thought would cover the tuner. Just for kicks, I set it to Tuner and then tried it, and it worked. I could see the note on the LT display. I then set Send Realtime Sysex back to all, and it works like it should. I don't know why this should have made a difference, but it is working as it should.

As always, thanks for the help.
 

cgscotto

Well-Known Member
Hi,
Well, I spoke too soon because it really was not working the way it should. I did find a solution, so I wanted to share it and also get some feedback. I still could be doing something wrong, but the way I have it set everything consistently works the way it should.

First, everything I read in the manual and saw in the RJM video suggests you need only one five pin cable to have tuner and tempo from the Axe-Fx II XL+ display on the Mastermind. Even the Fractal wiki on the RJM foot controllers. Second crucial step is to have Send Realtime Sysex set to All. I just could not get this to work, so I turned to the Axe manual. Here is what it said:

SEND REALTIME SYSEX
NONE/ALL/TUNER/TEMPO
Selectively determines whether real-time SysEx messages for TUNER and TEMPO will appear at the MIDI OUT port. The default setting of ALL ensures that a connected MFC-101 Midi Foot Controller will be able to show the Axe-Fx II Tuner on the floor, and that its TEMPO LED will flash in time with the current Axe-Fx II system tempo.

Notice it says turning this on will appear at the MIDI OUT port, so that tuner and tempo appears on the MFC-101 display. So I connected another five pin midi cable to the MIDI OUT port, and the tuner and tempo now consistently appear on the Mastermind LT. One additional point, I had to enable Ignore incoming PC on the Mastermind or else it would switch the Mastermind preset to the program change the Mastermind was sending to the Axe-FX. Once I did that, everything is working perfectly. Of course, one midi cable connected to the Mastermind would be cleaner, so if you have any suggestions, I would appreciate them.

All the best.
 

rjmmusic

Administrator
Staff member
I thought that the II XL+ had bidirectional capability, but it's been quite a few years since I've used one. I know that most of the Axe-Fx I and II models have bidirectional MIDI (perhaps all), and the III models don't. Do you have Bidirectional MIDI turned on in the LT's MIDI settings?
 

cgscotto

Well-Known Member
Yes, I have it turned on. Other things work, like the stae of IA switches. My XL+ has the Ares firmware, which I believe is from the III. I don’t know if that matters. Thanks.
 
Top