1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bad interface cable?

Discussion in 'Mastermind' started by Divide_By_Guitar, Apr 28, 2019.

  1. Divide_By_Guitar

    Divide_By_Guitar
    Expand Collapse
    Member

    Joined:
    Feb 24, 2017
    Messages:
    16
    Likes Received:
    0
    Hello! This might get sort of long winded but I think it will help to know the whole story. Anyway, I run a Mesa boogie mark 4 (rackmount) and an rg16. I recently moved everything into a new rack case and when I hooked it all back up exactly how I’ve had it for the past 2 years or so. My channel switching started acting up so I double checked my connections and tried again. While plugging and unplugging the mark 4 side of the cable the connector sparked and then burnt up the low voltage circuit in the amp. So, I take the amp out and have it repaired get the amp back and it’s fine. I also brought the interface cable with me to have that looked at Incase he can see something that I’m not. The channels all switch with the footswitch and the knob on the back. I now go back and try to use the interface cable like I always have and nothing on the amp. When I use the midi controller the lights and everything on the rg16 switch and the board works fine. This leads me to believe that the interface cable might have taken I hit during the short that messed up the amp??? Is there anyway to check that for sure?
     
  2. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,526
    Likes Received:
    972
    It sounds pretty likely that the cable has a issue as well. Can you turn the amp's EQ on using the RG-16?
     
  3. Divide_By_Guitar

    Divide_By_Guitar
    Expand Collapse
    Member

    Joined:
    Feb 24, 2017
    Messages:
    16
    Likes Received:
    0
    Sorry for the delay. I haven’t been back to the rehearsal space since the thread was posted. I can give you definite answer later this week. I want to say I remember the switches on the rg itself not changing the channels or anything.
     
  4. Divide_By_Guitar

    Divide_By_Guitar
    Expand Collapse
    Member

    Joined:
    Feb 24, 2017
    Messages:
    16
    Likes Received:
    0
    Update. When I turn on the rg 16. And the mark 4 I can hit all of the buttons on the rg16 and I can switch to the r2 channel 1 time an nothing else after that.
     
  5. Divide_By_Guitar

    Divide_By_Guitar
    Expand Collapse
    Member

    Joined:
    Feb 24, 2017
    Messages:
    16
    Likes Received:
    0
    Long story short...no
     
  6. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,526
    Likes Received:
    972
    The cable probably does need to be replaced - it has some electronics in it, so it's possible (but rare) for it to get fried.
     
  7. Divide_By_Guitar

    Divide_By_Guitar
    Expand Collapse
    Member

    Joined:
    Feb 24, 2017
    Messages:
    16
    Likes Received:
    0
    Thanks for helping me troubleshoot this. Looks like I’ll be ordering a new cable.
     
  8. Divide_By_Guitar

    Divide_By_Guitar
    Expand Collapse
    Member

    Joined:
    Feb 24, 2017
    Messages:
    16
    Likes Received:
    0
    Alright, so I have a new cable now and I also have two RG-16's

    When I turn the Mesa on, it comes straight to the LD+EQ channel/setting. If I press any of the 4 function switches (on either RG-16) it will switch back to R2, but thats the last thing that will happen no matter what gets pressed. On the original RG-16, I can't turn the FX Loop on or off, but on the new RG-16, I can. I've used the quick-setup option 4 (Hold function switch 4 at startup) to program both RG-16's. I've also tried option 8 as well as manually setting momentary and inverted modes but I'm pretty sure none of that is correct anyways so they're both set back to the standard 4-group setup.

    At this point we have no idea. The mesa works flawlessly with the mesa footswitch, so I don't believe it could be the amp itself. We've now got two different interface cables and they both appear to be behaving the same way. In case I haven't mentioned it, both cables on the second RG will turn the FXLoop on and off via button 5. The original RG will not do this, but otherwise they behave the same.

    Any ideas?
     
  9. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,526
    Likes Received:
    972
    I'm not sure what to say at this point, except that it sounds like relay #5 on the one RG-16 probably needs to be repaired. Is it the same whether you use the Amp 1 or Amp 2 output?

    If you bought the cable directly from us, it would have been tested before it shipped. That, and the fact that both cables do the same thing is pointing to the likelihood that it's not the cables. You can send the RG-16(s) in to us with the cables and we can have a look at them if you like.
     
  10. Divide_By_Guitar

    Divide_By_Guitar
    Expand Collapse
    Member

    Joined:
    Feb 24, 2017
    Messages:
    16
    Likes Received:
    0
    Amp 1 and amp2 performed the same on both units.

    Is there a factory reset and then known good function setup for the mkiv? I know on the mkiv footswitch it uses momentary switches, but I’m not sure if the amp actually sees that momentary switch or if it sees a latching switch due to logic controllers and such inside the fu-3. So I feel like the quick setup on function switch 4 (group of 4 latching switches and the rest default) is correct and that if it doesn’t work with that there’s not really anything else to try...but maybe a full factory reset is worth trying?

    While we’re at it, if I do send these in can you take a look at the power connector on one of them? When we were messing with all last night we noticed that it’s loose and can be finicky to get a solid power connection.
     
  11. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,526
    Likes Received:
    972
    There isn't a factory reset on the RG-16, unfortunately, but doing a quick setup like you did is pretty close - it just doesn't erase any presets you've made.
     
  12. Divide_By_Guitar

    Divide_By_Guitar
    Expand Collapse
    Member

    Joined:
    Feb 24, 2017
    Messages:
    16
    Likes Received:
    0
    How would I go about sending everything in to you guys?
     
  13. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,526
    Likes Received:
    972
    Email us at support@rjmmusic.com and we'll start the process.
     

Share This Page