Disaster Area SmartClock Gen3 with MMGT16 help?

Hello all. I'm new here, but I've been using my MMGT16 for a while running a bunch of pedals in a rack with several Voodoo Lab Hex's, a Whammy DT, a Line 6 M5, and recently added a Disaster Area SmartClock Gen3 to be able to control the tap tempo inputs on a couple pedals (JHS, Walrus, etc). The SmartClock works like it should with the pedals when tested on its own. The tap tempo coming out of the MMGT is being seen by the Line 6 M5. So I'm not entirely sure where my problem lies. The MMGT and the SmartClock just don't seem to want to talk to one another. I am certain that it's set to the proper midi channel. This is all their manual says:
"MIDI Input and Output

While the SMARTClock can generate MIDI clock and program change messages on its own, it can also function as part of a larger MIDI system thanks to its MIDI input and USB MIDI ports.

To use the SMARTClock with a Disaster Area or other MIDI controller, change the InCH setting in the Setup menu to match the channel that your master controller sends. If you are connecting to a Disaster Area controller, set InCH = 16. We also recommend you disable the MIDI clock sending on your master controller, if possible. Disaster Area controllers should set CLK = OFF or TAP.

If InCH is set to OFF, the SMARTClock MIDI thru will be disabled. The SMARTClock responds to the following MIDI messages:



Program Change 0-127: Change preset 0-127

ContinuousController93: TapTempo

MIDI Beat Clock: Disables internal clock
MIDI Stop: Disables internal clock

MIDI Continue: Re-send tap tempo pulses

External MIDI Clock

Note that if the SMARTClock receives MIDI clock from an external source, its internal clock will be disabled.
The display will show E in addition to the BPM to indicate that it is receiving clock. If the external clock signal is removed or lost, the SMARTClock will restart its internal clock using the last BPM received.

Sending the SMARTClock a MIDI Continue message will cause the controller to re-send the tap tempo pulses."


I tried turning the midi clock off on the MMGT but it didn't do any good. I'm guessing this is an issue with the Disaster Area stuff, but I'm just hoping it's a setting or something I'm missing in the editor or maybe the way I set up the device (I attached a photo of the device setup page... I just picked generic and left the defaults). Maybe just a box I'm not ticking that can fix it. I'm very good at the advanced parts of midi, so any advice is appreciated.
 

Attachments

  • Screen Shot 2020-08-18 at 4.29.05 PM.png
    Screen Shot 2020-08-18 at 4.29.05 PM.png
    116.7 KB · Views: 4

rjmmusic

Administrator
Staff member
Can you describe what exactly that it's doing when the GT is not involved, and what it's not doing when the GT is connected?
 
Can you describe what exactly that it's doing when the GT is not involved, and what it's not doing when the GT is connected?
If I understand what you’re asking, when I disconnect the midi cables from the smartclock Midi in and tap a tempo into the smartclock itself to test whether it is sending a tempo on to the pedals downstream, it is working properly.
When I connect the midi cable to the midi in of the smartclock, and then tap a tempo into the MMGT16, the tempo is not changing on the smartclock or the pedals downstream. Nothing at all is happening at the smartclock. As I mentioned, though, the M5 is getting the tapped in tempo from the MMGT16. I feel like maybe I just haven’t set the device up properly in the editor. Although I believe it’s also entirely possible that this particular Disaster Area pedal, as with their past devices, may just not work with some stuff. I specifically bought the Gen3 because I’d thought it was going to be “universal”, but I’ve also heard their stuff just sometimes doesn’t work with other stuff.
 
The MMGT is set up as the Master and the Smart Clock isn't getting tempo. But at one point I did try, as the manual in the Smart Clock suggests, changing it to "off", but that didn't work either. Not sure why the Disaster Area manual suggests that.
 
Last edited:

rjmmusic

Administrator
Staff member
On your tempo button, do you have "flash w tempo" turned on? That needs to be on for it to work with the MIDI clock generator.
 
On your tempo button, do you have "flash w tempo" turned on? That needs to be on for it to work with the MIDI clock generator.
Yes, that’s on. Again, the Line 6 M5 is getting the tempo just fine. But that’s also a device that’s already in the device list on the device setup page. With the Disaster Area, I just had to pick “Generic Device” so I’m not sure my settings for it are correct on the device settings page.
 

rjmmusic

Administrator
Staff member
MIDI clock isn't sent on any channel, it always goes to all devices, so you don't even need to have a device entry for the Smart Clock and it would still get clock.

Send me your settings file if you like, I can have a look at them.
 

rjmmusic

Administrator
Staff member
I don't see anything wrong with the settings. That, coupled with the fact that the GT controls the M5 just fine leads me to believe there's something up with the Smart Clock.
 
I don't see anything wrong with the settings. That, coupled with the fact that the GT controls the M5 just fine leads me to believe there's something up with the Smart Clock.
That’s kinda what I was afraid of. I mean it does work on its own so it’s probably that it just isn’t compatible with all gear, which I think is a problem of theirs from time to time, or something within the settings in the SmartClock itself. Anyway, thanks so much for taking the time to help me. I love my MMGT16!!!!!
 
So, just thought I'd put an update if anyone has the same issue... I was able to get ahold of Disaster Area, and after trying a few things he suggested, he asked me to send the pedal back for repair. They repaired the pedal, sent it back to me, and now it works just as it should.
 
Top