1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

error 2

Discussion in 'GT General Discussion' started by Mr.E, Jun 2, 2019.

  1. Mr.E

    Mr.E
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 12, 2014
    Messages:
    154
    Likes Received:
    18
    While transferring a setup to the GT-22, I got an error : "Error 2".
    i had to restart the GT and the editor.
     
  2. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,736
    Likes Received:
    1,006
    Wow, I don't even know what that would be. I'm assuming this error showed up on the computer, not the GT? And, are you using a Windows PC?
     
  3. Mr.E

    Mr.E
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 12, 2014
    Messages:
    154
    Likes Received:
    18
    It was on the GT
     
  4. Mr.E

    Mr.E
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 12, 2014
    Messages:
    154
    Likes Received:
    18
    I was programming some songs (for the first time) and got the same error when transferring to the GT.
    I did a factory reset, installed 4.30 and transferred the settings again without a problem.
     
  5. Mr.E

    Mr.E
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 12, 2014
    Messages:
    154
    Likes Received:
    18
    It happened again.
    First transfer went OK, the second gave the same error.
    It happened after swapping presets in the editor.
    I restarted the GT and the editor, downloaded the settings from the GT an noticed that the presets were swapped in the preset list but in the songs list they weren't.
    To be specific:
    preset 201 was "Cameron & Friedman"
    preset 202 was "Plexi 6550/2204"

    I swapped those (to match the order in which they are sorted in the Axe-Fx)
    The songs kept their respective presets - 201 stayed 201 and 202 stayed 202.
    Where you would expect these also tho have been swapped.
    Unless there's no link between the presets themselves but only with the preset number.
     
  6. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,736
    Likes Received:
    1,006
    Please send me your settings file, and I'll see if I can reproduce the problem here.
     
  7. Mr.E

    Mr.E
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 12, 2014
    Messages:
    154
    Likes Received:
    18
    I tried it with this setup.
    In preset 200 I changed the following:
    Chorus Delay: move right
    Changed scene to scene 1
    turn on Chorus1 and Delay1 both with Off: none

    Then copied this to the left and changed the name to Chorus, removd the delay on command.
    When sending the settings, the editor did not respond and after restarting could not coneect tot he GT.
    After restarting the GT, I could send the settings.

    Funny thing is, now I've also switched presets 201 and 202 and now it transfers fine.
     

    Attached Files:

  8. Mr.E

    Mr.E
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 12, 2014
    Messages:
    154
    Likes Received:
    18
    My PC-configuration:
    Microsoft Windows 10 Enterprise Version 10.0.17134 Build 17134
    LENOVO_MT_10MN_BU_LENOVO_FM_ThinkCentre M910t
    Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz, 3600 MHz, 4 core('s), 8 logic processors
    RAM: 32,0 GB
     
  9. Mr.E

    Mr.E
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 12, 2014
    Messages:
    154
    Likes Received:
    18
    I just tried to reload the last settings I saved befor trying to reacrate what whent wrong and I got the Error 2 again.
    This is the file I tried to load:
     

    Attached Files:

  10. Mr.E

    Mr.E
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 12, 2014
    Messages:
    154
    Likes Received:
    18
    I tried again, this time with the Axe-Fx turned off and it worked.
    I don't know if that could have something to do with it.
     
  11. AdrianG

    AdrianG
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 15, 2018
    Messages:
    48
    Likes Received:
    13
    I just got Error 2 when writing an update from the Editor to my GT22 and had to reboot the GT to operate normally again. I'm not 100% sure what my exact steps are, so I will update here once I have them. I think it was possibly to do with sending a large update to the GT, and the smaller ones seem to be ok but I will try to confirm this.

    I am on Axe-FX FW5.08, and GT22 FW4.3 using a MacBook Pro.

    ERROR2 small.jpg
     
  12. Mr.E

    Mr.E
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 12, 2014
    Messages:
    154
    Likes Received:
    18
    In the description of the last firmware update it says:
    When I installed the beta, I saw this but not with the two times I installed the latest firmware
     
  13. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,736
    Likes Received:
    1,006
    This, at least, I can say is normal. The button board firmware didn't change from the beta to the release.
     
  14. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,736
    Likes Received:
    1,006
    Still working on the Error 2 thing, no idea where that's even coming from!
     
  15. AdrianG

    AdrianG
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 15, 2018
    Messages:
    48
    Likes Received:
    13
    I had the error twice this evening, and have never seen it before. Annoyingly I am struggling to recreate it, however my first theory of it being a large update (i.e. lots of changes from the Editor) is not correct as I have just tried to recreate that unsuccessfully.

    I don't know if this is related, but before the error appeared, my GT22 was acting very strangely. The Preset + and - IAs were taking me to Preset 129 when I was on a completely different preset. I did not change those buttons at all, and did not reboot the Axe-FX3, but after the Error 2 then that problem went away and the GT22 seems perfectly fine now (as it does most of the time). I've reported the same problem with slight differences in another thread, so I don't want to hijack this thread, however I thought I would mention it if it could be a clue/step closer to the Error 2 (or maybe they are completely different things).
     
  16. Mr.E

    Mr.E
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 12, 2014
    Messages:
    154
    Likes Received:
    18
    Even after a factory reset?
     
  17. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,736
    Likes Received:
    1,006
    Correct, button board firmware only updates when the firmware stored on the main board is newer than what's stored on the button boards. Factory reset doesn't affect the firmware, only the stored settings. There's an "Update Button FW" option in the System Functions menu in on-board setup that will force the firmware to download, but otherwise it only happens when the need for an update is detected.
     
    Mr.E likes this.
  18. Mr.E

    Mr.E
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 12, 2014
    Messages:
    154
    Likes Received:
    18
    Now I got the "Error 2" by simply setting a button to "Off" in the local Buttons Page and transferring
     
  19. Mr.E

    Mr.E
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 12, 2014
    Messages:
    154
    Likes Received:
    18
    The Error 2 popped up again after simply changing some commands in two buttons
     
  20. Mr.E

    Mr.E
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 12, 2014
    Messages:
    154
    Likes Received:
    18
    And again when swapping two presets
     

Share This Page