1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Eventide H9 performance switch set up

Discussion in 'PBC General Discussion' started by Chuck Hanning, May 13, 2020.

  1. Chuck Hanning

    Chuck Hanning
    Expand Collapse
    Well-Known Member

    Joined:
    Apr 19, 2016
    Messages:
    46
    Likes Received:
    2
    So previously I had a separate button for H9 performance switch and now have changed it to be the second press for preset that has the h9 in it. It took a while to figure out I needed toggle not momentary.

    my problem is that the first time I press the button to activate it, it doesn’t work. But then thereafter it does. However I have lights changing to indicate whether it’s on or off which are actually out of sync one cycle due to problem above. Is there some update on preset change I need or when I first change preset do I need to include cc toggle to turn performance switch off?

    thanks for your advice
    Chuck
     
    eastern likes this.
  2. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,288
    Likes Received:
    1,121
    Try reversing the values on the CC. If it was off:0 on:127, make it off:127 on:0 - that may fix it.
     
  3. eastern

    eastern
    Expand Collapse
    Member

    Joined:
    Aug 20, 2019
    Messages:
    9
    Likes Received:
    0
    Excellent idea. I'm trying to figure out how I would configure performance switches on my two H9s. Would you mind explaining more details on how you implemented it? Is it done via IA mode or alt preset? Thanks!
     
  4. Chuck Hanning

    Chuck Hanning
    Expand Collapse
    Well-Known Member

    Joined:
    Apr 19, 2016
    Messages:
    46
    Likes Received:
    2
    Ron-I tried this and it didn’t work.

    So as part of a preset I added a cc toggle to send value of 127 for on. This didn’t immediately turn on hot switch, but then after preset was selected and pressed a second time for IA (selected in the globals tab, eastern) actions, this did turn on hot switch. However this seems to work only for the H9 algorithms.

    I'm also trying this for two other algorithms one of which is a time factor and the other is pitch factor. For these two algorithms it doesn't work immediately; you have to go through one on and off cycle, and then it starts to work. Also supposedly the time factor algorithms need a value of 64 for both on and off. Not straightforward.

    So it seems like this is work in progress. I thought since the H9 handles it differently it would be better if I used the 2nd press of preset to call an IA action that I can customize for the algorithms I'm using. But I haven't got it to work consistently.
     
  5. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,288
    Likes Received:
    1,121
    That's what 2nd press does - it starts working on the 2nd press of a preset button, not the first.

    If you want a preset to automatically turn on the Performance switch when the preset is selected, I recommend this:

    - Create an IA button that controls the performance switch. Doesn't matter what page it's on, you won't even necessarily be pressing it.
    - Make sure that the button has Send on Preset Change and Update on Preset Change turned on.
    - Now, in the Presets tab, you can use the Buttons panel at the bottom to progeam the button. Select a preset in the Presets tab, go to the button page where your Performance button is, and click it (in the app) to turn in on. The Mastermind will remember that and automatically turn on the button when the preset is selected, sending the Performance CC to the pedal. You can do this for any preset(s).
     
  6. Chuck Hanning

    Chuck Hanning
    Expand Collapse
    Well-Known Member

    Joined:
    Apr 19, 2016
    Messages:
    46
    Likes Received:
    2
    For the h9 algorithms the hot button works on the second press as expected. But in order to get it to work I had to add a cc toggle as part of the preset command. In this case the only choice is on and the associated value.

    For the time factor and pitch factor it doesn’t start to work until the fourth press. I did include the same command in the preset actions.
     

Share This Page