firmware update error

Victor Vos

Well-Known Member
Hello,

I tried to update the GT firmware. When I start up with 4.9.1 on a stick I get the error message: "error loading block 112" and more text, I can't read as it disappears...
And now it will not start up at all...
What should I do? I tried all firmware back to 4.7.0 but they all error the same...
 

rjmmusic

Administrator
Staff member
I recommend trying a different flash drive. Also, when copying the file to the drive, make sure to select the Eject option on the computer before removing it, that makes sure the entire file is written to the flash drive.
 

Victor Vos

Well-Known Member
Why not? Should I look for serial number? And what firmware would work? I also tried earlier versions..
Or do you mean that newer versions can update using the editor..? Don't know..
 

rjmmusic

Administrator
Staff member
Are your flash drives formatted with FAT (PC) format? They won't work if they're Mac formatted.

You can find out about the firmware update capabilities by starting the GT with both of the small buttons under the main screen held in. It should display a Mastermind GT Bootloader message. Versions 2.0 and higher can perform a firmware update from the editor.
 

Victor Vos

Well-Known Member
I'm not sure about my flash drives.. It worked before...I will try today on a windows machine.

I have version 1.2...
 

Victor Vos

Well-Known Member
I found an old USB stick containing firmware 4.3 that worked before and tried starting up with that but I get the same error.
I'm afraid I'll have to say goodbye...
 

rjmmusic

Administrator
Staff member
If you'd like to send the GT in (or just the main CPU board) to us, I'm sure we can fix it.
 

rjmmusic

Administrator
Staff member
You're in Europe, right? I recommend sending just the CPU board (the one with all the connectors on it) to us. We have someone in Europe that fixes some things for us, but they're better at audio repairs. Something like this would be better for me to handle. Sending just the CPU board should keep the costs down.

Please email us at support@rjmmusic.com if you'd like to start the process.
 
Top