1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MIDI Clock: Auto - Not Working Properly

Discussion in 'LT General Discussion' started by aaronf, Jul 31, 2019.

  1. aaronf

    aaronf
    Expand Collapse
    Member

    Joined:
    Aug 23, 2017
    Messages:
    18
    Likes Received:
    1
    I have my Mastermind LT connected to Ableton via USB.
    When MIDI Clock is set to Slave it all works perfectly, it reads the clock information from Ableton, displays the Tempo on screen and controls the scenes in Ableton with CC's - all no problem.

    When I don't have my LT connected to Ableton and set MIDI Clock to Master it controls my pedals perfectly, I can use tap tempo button I set up and it changes tempo to the MIDI Clock I preset for each song - all no problem.

    However as the title suggests when I set MIDI Clock to Auto it does not work as expected. It essentially acts as thought it's still set to Master - I can still control Ableton with CC's so I know they're connected properly but no matter how many times I stop and start the clock or change the tempo in Ableton the LT does not register clock at it's input and carries on as though it's still the master. If I change MIDI Clock back to Slave it immediately works, but then obviously once I disconnect it from Ableton I have to go back into the editor to change it back to Master so I can control my pedals as normal.

    Have I potentially glossed over a setting required to make this work properly? I know MIDI is reaching my LT but as I mentioned I cannot get it to 'register' and auto switch between Master and Slave. Any insight would be greatly appreciated.
     
  2. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,683
    Likes Received:
    998
    It sounds like you're doing the right thing (the Auto setting should be all that's required), but clearly something is going on. Are you running the latest firmware on the LT?
     
  3. aaronf

    aaronf
    Expand Collapse
    Member

    Joined:
    Aug 23, 2017
    Messages:
    18
    Likes Received:
    1
    Thanks for your speedy response!
    No I noticed I was a couple of firmware updates behind so I've just updated both my LT and editor to 4.3.0 and run a quick test and the issue remains - it does not detect clock in Auto but does detect it in Slave.

    For reference I have attached the .rjs file I have been using, hopefully I have simply missed a checkbox and it's an easy fix.
     

    Attached Files:

Share This Page