1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Preset Menu selection reverts back to Previous Preset. GT 22 Axe FX III

Discussion in 'GT General Discussion' started by UncleMatt, Dec 14, 2019.

  1. UncleMatt

    UncleMatt
    Expand Collapse
    Member

    Joined:
    Dec 9, 2019
    Messages:
    17
    Likes Received:
    1
    When I select a preset from the "preset menu" page it will not change, but reverts back to previous preset.

    - I can change the preset manually on the Axe FX III and it will update on GT 22.
    - On preset menu page the currently selected preset is "on", but will not switch to a new preset.

    I am new the GT so I am sure I am missing something simple. Thanks for any help!
     
  2. UncleMatt

    UncleMatt
    Expand Collapse
    Member

    Joined:
    Dec 9, 2019
    Messages:
    17
    Likes Received:
    1
    I thought I fixed it, but its reverting back again to previous preset.
     
    #2 UncleMatt, Dec 14, 2019
    Last edited: Dec 14, 2019
  3. UncleMatt

    UncleMatt
    Expand Collapse
    Member

    Joined:
    Dec 9, 2019
    Messages:
    17
    Likes Received:
    1
    See what is happening here:
     
  4. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,989
    Likes Received:
    1,081
    Does the MIDI channel set in the Devices tab of the GT match the MIDI channel set on the Axe-Fx's MIDI settings?
     
  5. UncleMatt

    UncleMatt
    Expand Collapse
    Member

    Joined:
    Dec 9, 2019
    Messages:
    17
    Likes Received:
    1
    Yes both are on channel 1.
     
  6. UncleMatt

    UncleMatt
    Expand Collapse
    Member

    Joined:
    Dec 9, 2019
    Messages:
    17
    Likes Received:
    1
    #6 UncleMatt, Dec 14, 2019
    Last edited: Dec 14, 2019
  7. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,989
    Likes Received:
    1,081
    When you select a preset from the preset menu, does the Axe-Fx change briefly to the requested preset, then back to the previous preset (like the GT screen does)?

    Also, make sure that PC Mapping is turned off in the Axe-Fx.
     
  8. UncleMatt

    UncleMatt
    Expand Collapse
    Member

    Joined:
    Dec 9, 2019
    Messages:
    17
    Likes Received:
    1
    No, the Axe-Fx screen does not change.

    PC mapping is off.
     
    #8 UncleMatt, Dec 14, 2019
    Last edited: Dec 14, 2019
  9. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,989
    Likes Received:
    1,081
    It seems like the GT is not changing the Axe-Fx preset for some reason, then Poll State is correcting the GT''s preset to match the Axe-Fx. Try turning off Poll State in Devices on the GT, and see if you can get the Axe-Fx to change presets.
     
  10. UncleMatt

    UncleMatt
    Expand Collapse
    Member

    Joined:
    Dec 9, 2019
    Messages:
    17
    Likes Received:
    1
    I turned off “poll state”, the GT changed preset names (via the preset menu), but was not switching the Axe-Fx III.
     
  11. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,989
    Likes Received:
    1,081
    Ok, so that is the problem for sure. Is the GT successfully controlling other things on the Axe-Fx, like effect blocks?
     
  12. UncleMatt

    UncleMatt
    Expand Collapse
    Member

    Joined:
    Dec 9, 2019
    Messages:
    17
    Likes Received:
    1
    Yes, effects blocks work fine. Looper works. Just can’t change preset.
     
  13. UncleMatt

    UncleMatt
    Expand Collapse
    Member

    Joined:
    Dec 9, 2019
    Messages:
    17
    Likes Received:
    1
    I used the "get preset names" 0-20, but it went to I (I think) preset 123 and loaded them at the 00 preset. So now it has loaded the names wrong out of order.

    I wanted to share this in case it helps diagnose what's going on... very weird. I just want to access presets.

    At what point do I factory reset everything? Or will I still need to trouble shoot this?
     
    #13 UncleMatt, Dec 15, 2019
    Last edited: Dec 15, 2019
  14. UncleMatt

    UncleMatt
    Expand Collapse
    Member

    Joined:
    Dec 9, 2019
    Messages:
    17
    Likes Received:
    1
    I did a factory reset, and reloaded original page settings (@iaresee thanks for sharing) and the preset menu works again. I loaded my custom pages back and its doing the reverting to previous preset again. I made a change somewhere that is making it act up... I can't find it, so I guess I am just going to start over.

    Not a huge deal, but very curious what was causing this to happen.
     
  15. UncleMatt

    UncleMatt
    Expand Collapse
    Member

    Joined:
    Dec 9, 2019
    Messages:
    17
    Likes Received:
    1
    SOLVED (I saved each page separately and loaded them one by one until the issue was uncovered).

    Page 6 was the culprit. I was experimenting with using external switch 1 to be a global preset selection, not sure why it caused the problems it did... Hopefully someone smarter then me can explain what is going on.

    Here is what is selected:

    ExtSw 1

    Normal
    IA

    IA settings:
    on - send on preset change
    on - update on preset change

    IA Actions:
    Axe-Fx III / PC off: 0 on:2
     
    iaresee likes this.
  16. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    5,989
    Likes Received:
    1,081
    Send on Preset Change is the culprit. When it's turned on, it'll send its message(s) every time you change presets, so it's jumping back to preset 1 every time you change presets, then Poll State makes the GT follow the Axe-Fx's preset change.

    Sorry I missed that before - I should have caught that in your settings.
     
    iaresee likes this.
  17. Andrew Slotta

    Andrew Slotta
    Expand Collapse
    New Member

    Joined:
    Dec 18, 2019
    Messages:
    1
    Likes Received:
    0
    What do the settings need to be because I am having this issue on mine now after updating the other day and I have a gig on Saturday.
     
  18. UncleMatt

    UncleMatt
    Expand Collapse
    Member

    Joined:
    Dec 9, 2019
    Messages:
    17
    Likes Received:
    1
    @Andrew Slotta I checked "send on preset change" on one of my button's (on a different page) that had an IA action to go to preset 1. When I made a preset change it also triggered this other button to make the change, thus reverting it back to preset 1 no matter what.

    I would go through your buttons page and see if that is checked anywhere and sending a conflicting message.
     

Share This Page