1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Axe Fx III: Tuner on expression pedal heel down?

Discussion in 'GT General Discussion' started by Megahertzz, Aug 6, 2019.

  1. Megahertzz

    Megahertzz
    Expand Collapse
    Active Member

    Joined:
    Jun 7, 2019
    Messages:
    28
    Likes Received:
    4
    I'm using the toe switch on my Mission EP1-RJM to switch between engaging and controlling volume or wah, and i want to have the tuner engaged when the pedal is used to control the volume (LED off), and in heel down position.
    Is there any way of making this happen?
     
    Alexander likes this.
  2. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,424
    Likes Received:
    1,158
    Are you using a System / Exp Pedal action to switch the expression pedal's functions? If so, just edit the Position Switch Actions to do nothing in the expression pedal settings for the wah, and add a System / Tuner and CC Toggle / Axe-Fx III Tuner action to the expression pedal settings for the volume pedal.
     
    Megahertzz likes this.
  3. Megahertzz

    Megahertzz
    Expand Collapse
    Active Member

    Joined:
    Jun 7, 2019
    Messages:
    28
    Likes Received:
    4
    I am not. The switch between volume and wah is set up per preset in the Axe Fx. I like to be able to use the toe switch for other effects when i'm not using wah in the preset. But the pedal always controls volume when the toe switch LED is off.
    Is there a way to tell the GT to turn on the tuner IF the toe switch is OFF, AND the pedal is in heel down?

    btw, I'm pretty much an idiot when it comes to MIDI.
     
  4. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,424
    Likes Received:
    1,158
    Edit the "Exp Pedal 0" settings block in global settings. Make it have the same settings as your main expression pedal settings, but add a System / Tuner action to the Position Switch Actions at the bottom of the page. Also, check the Invert Position Switch checkbox.

    In the external switch settings, add a this action: System / Exp Pedal #1 off:0 on:Global. This will select the expression pedal settings that allow the tuner to turn on when the switch is off, and will select the expression pedal settings that don't activate the tuner when the switch is on.

    After you send these settings to the GT, go into settings mode on the GT itself, and go to Exp Pedals / Exp Pedal 1. Then, put the expression pedal in the position where you want the tuner to activate (when it goes below that position), and press Set Switch Position on the GT. Read the settings back into the editor and save them.
     
    Megahertzz likes this.
  5. Megahertzz

    Megahertzz
    Expand Collapse
    Active Member

    Joined:
    Jun 7, 2019
    Messages:
    28
    Likes Received:
    4

    Thank you so much. I'll try this.
     
  6. Megahertzz

    Megahertzz
    Expand Collapse
    Active Member

    Joined:
    Jun 7, 2019
    Messages:
    28
    Likes Received:
    4
  7. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,424
    Likes Received:
    1,158
    There does appear to be something going on with the position switch - it's not registering like it should. I'll need some time to investigate.
     
  8. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,424
    Likes Received:
    1,158
    Found it, it will be fixed in 4.3.1, probably coming out next week.
     
    Megahertzz likes this.
  9. Megahertzz

    Megahertzz
    Expand Collapse
    Active Member

    Joined:
    Jun 7, 2019
    Messages:
    28
    Likes Received:
    4
    Thank you!
     
  10. Megahertzz

    Megahertzz
    Expand Collapse
    Active Member

    Joined:
    Jun 7, 2019
    Messages:
    28
    Likes Received:
    4
    Has the issues with the position switch been worked out, is it possible to program the GT to turn on the tuner on volume pedal heel down now? I'm still very much in the dark about advanced midi programming, so any help would be appreciated.
     
  11. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,424
    Likes Received:
    1,158
    I did fix an expression pedal position issue in the last release. You may need to set your pedal position again, but that should be all that's required to make it work.
     
    Megahertzz likes this.
  12. UncleMatt

    UncleMatt
    Expand Collapse
    Member

    Joined:
    Dec 9, 2019
    Messages:
    17
    Likes Received:
    1
  13. Megahertzz

    Megahertzz
    Expand Collapse
    Active Member

    Joined:
    Jun 7, 2019
    Messages:
    28
    Likes Received:
    4
    I haven't had the time to try it out, unfortunately.
     
  14. Megahertzz

    Megahertzz
    Expand Collapse
    Active Member

    Joined:
    Jun 7, 2019
    Messages:
    28
    Likes Received:
    4
    I updated the firmware and followed the instructions above. I think i'm a little closer now, The tuner activates on the MMGT but not on the Axe Fx. The display on the GT shows a big question mark, which I would guess is because the tuner isn't engaging on the Axe FX. Am I not supposed to use CC toggle action to engage the tuner on the Axe Fx in here somewhere?
     
  15. Megahertzz

    Megahertzz
    Expand Collapse
    Active Member

    Joined:
    Jun 7, 2019
    Messages:
    28
    Likes Received:
    4
    I got the tuner working by adding a CC toggle #35 (tuner) in the Exp pedal 0 settings, but it engages regardless if toe switch is on or not. I'm guessing there should be something programmed into the settings of the toe switch (Ext. sw 1) to ignore the tuner when the switch is on?
     
  16. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,424
    Likes Received:
    1,158
    You'll need to use expression pedal settings blocks. Edit the Exp Pedal 0 block in Globals. Make it the same as your existing expression pedal settings, except remove the tuner actions. Then, on the external switch, add an action like this:

    System / ExpPedal: off:Global on:0

    When the switch is on, it will use the settings with no tuner, and when the switch is off, it will use the global settings that include the tuner.
     
  17. Megahertzz

    Megahertzz
    Expand Collapse
    Active Member

    Joined:
    Jun 7, 2019
    Messages:
    28
    Likes Received:
    4
    It worked! Thanks!
    But I have another issue now, there's a latency issue when using the pedal. Even slow movement makes the modifier on the Axe FX jump back and forth to keep up with the movement of the pedal, instead of getting a smooth swell.

    GT setup file and Axe FX preset example below:

    https://www.dropbox.com/s/78467pe26a4na38/Basic setup.rjs?dl=0

    http://axechange.fractalaudio.com/detail.php?preset=7607

    It's not a CPU issue on the Axe FX, it happens even if I have a preset with just a volume or wah block and nothing else.
     
  18. Megahertzz

    Megahertzz
    Expand Collapse
    Active Member

    Joined:
    Jun 7, 2019
    Messages:
    28
    Likes Received:
    4
    It's not latency, it's the tuner that somehow interferes with the modifier the pedal is controlling. Instead of a smooth volume swell from completely silent, it jumps directly to not-so silent and tracks from there.
     

Share This Page