[BUG]Axe FX III connected to GT22 doesn't register the full sweep of my expression pedals

Megahertzz

Active Member
I have a GT22 with two Mission Engineering SP-1RJM connected, which i use with my Axe FX III. The Axe won't register the entire sweep of either of my expression pedals, i.e. from 0 to 100% (or 0 to 10, depending on parameter i want to control). I have tried calibrating both pedals several times, and each time both pedals stop at 99.2% or 98.4%, depending on which parameter the pedals are controlling, but it's always the same for both pedals. Cliff from Fractal says it's NOT an issue with the Axe FX, so that leaves the MMGT22. I have also opened up the pedals to check for loose parts that might affect the sweep of the potentiometer, but everything is as it should be.
 

rjmmusic

Administrator
Staff member
Ok first thing to try: check your expression pedal settings on the GT and make sure that the minimum value is 0 and max is 127.

Then, if you have a computer set up to monitor MIDI messages, it would be good to see what's coming out of the GT.

And, you could try calibrating, but don't move the pedal all the way to the toe down position, stop just a little short of maximum.
 

Megahertzz

Active Member
Ok first thing to try: check your expression pedal settings on the GT and make sure that the minimum value is 0 and max is 127.

Then, if you have a computer set up to monitor MIDI messages, it would be good to see what's coming out of the GT.

And, you could try calibrating, but don't move the pedal all the way to the toe down position, stop just a little short of maximum.


I don't know how to set up my computer to monitor MIDI messages, but aside from that I've checked the things you mention. Still doesn't go all the way up. As a last resort I'll try loading an earlier firmware on the Axe FX and see if anything changes.
 

Megahertzz

Active Member
Now this just happened, and I can't make it go away!
https://imgur.com/yKSvMz6

 

rjmmusic

Administrator
Staff member
What process are you using to calibrate the pedal? Are you calibrating on the GT or on the Axe-Fx?
 

rjmmusic

Administrator
Staff member
I'm calibrating on the GT. I haven't found any way to calibrate pedals connected through MIDI on the Axe FX.

Without the ability to MIDI monitor, the only thing I can recommend is to recalibrate it again, this time only moving the pedal from heel down to the half way point, so that it hits maximum when it's halfway up. This setting will insure that the pedal sends its maximum value to the Axe-Fx - any position past half way should send the maximum. Let's see if we can get it to hit 100% with those settings.
 

Megahertzz

Active Member
Without the ability to MIDI monitor, the only thing I can recommend is to recalibrate it again, this time only moving the pedal from heel down to the half way point, so that it hits maximum when it's halfway up. This setting will insure that the pedal sends its maximum value to the Axe-Fx - any position past half way should send the maximum. Let's see if we can get it to hit 100% with those settings.
I tried that yesterday. Didn't hit 100%. I reinstalled the latest Axe FX firmware, reset all midi settings on both Axe FX and GT22, and I even disconnected the pedals. Did the entire setup from scratch and connected and calibrated the pedals. That seemed to work, for now.
 

Rain

Well-Known Member
I'm having the same problem with my MMGT22 and 2 EV-1's Firmware 441rjf. Latest Axe FX III Firmware. I'm going to check my old Korg Expression Pedals and see if they do the same thing..
 

rjmmusic

Administrator
Staff member
I'm having the same problem with my MMGT22 and 2 EV-1's Firmware 441rjf. Latest Axe FX III Firmware. I'm going to check my old Korg Expression Pedals and see if they do the same thing..

When using EV-1s, are you using a cable to reverse their polarity? That's needed for sure with those.
 

Rain

Well-Known Member
When using EV-1s, are you using a cable to reverse their polarity? That's needed for sure with those.
Yes custom made by Best-Tronics.

I tried your suggestion...
“Without the ability to MIDI monitor, the only thing I can recommend is to recalibrate it again, this time only moving the pedal from heel down to the half way point, so that it hits maximum when it's halfway up. This setting will insure that the pedal sends its maximum value to the Axe-Fx - any position past half way should send the maximum. Let's see if we can get it to hit 100% with those settings.”

That’s seems to work, but is that a fix ?
 
Last edited:

rjmmusic

Administrator
Staff member
Yes custom made by Best-Tronics.

I tried your suggestion...
“Without the ability to MIDI monitor, the only thing I can recommend is to recalibrate it again, this time only moving the pedal from heel down to the half way point, so that it hits maximum when it's halfway up. This setting will insure that the pedal sends its maximum value to the Axe-Fx - any position past half way should send the maximum. Let's see if we can get it to hit 100% with those settings.”

That’s seems to work, but is that a fix ?

It can be a fix if you try recalibrating with the "down" position closer to the full toe down position. Try doing the process again, but with the pedal 80% or 90% down instead of 50% down. You might be able to get a setting that works well enough.

If the cable is correct, then the expression pedal port may be starting to go. Have you tried different ports on the GT?
 

Rain

Well-Known Member
It can be a fix if you try recalibrating with the "down" position closer to the full toe down position. Try doing the process again, but with the pedal 80% or 90% down instead of 50% down. You might be able to get a setting that works well enough.

If the cable is correct, then the expression pedal port may be starting to go. Have you tried different ports on the GT?
Thanks Ron I'll try that today ...
 

Megahertzz

Active Member
I'm reviving this thread because it's still an issue for me. FX3 FW. 14.00, MMGT22 FW. 4.5.1.

Mission pedals connected to the MMGT22 have been calibrated several times, still maxes out at 9.92 on wah block, 9.84 on volume block, and most annoying, 98.4 on pitch block. After a few seconds it sometimes jumps up to 10. Whammy effect is completely useless. Hoping there can be a solution to this once and for all.

Cross post of the Fractal forum thread
 

rjmmusic

Administrator
Staff member
Are you sure you're calibrating correctly? This is the process:

- Enter setup on the GT
- Select Expression Pedals
- Select the number of the expression pedal you want to calibrate
- Start with the pedal in roughly the middle position
- Select Calibrate
- Sweep the pedal almost all the way up and almost all the way down. Normally, I would say go all the way up and all the way down, but since there appears to be an issue at the ends of the sweep, keeping it away from the ends in calibration would be a good idea
- Press a key to end calibration
- Press Done a few times to exit setup
- Read the settings back into the editor and save them. If you don't save the file and use it as a basis for all future changes, you'll lose the calibration settings.

If that doesn't work, we'll have to try a MIDI monitor to see what's going on.
 

Megahertzz

Active Member
Are you sure you're calibrating correctly? This is the process:

- Enter setup on the GT
- Select Expression Pedals
- Select the number of the expression pedal you want to calibrate
- Start with the pedal in roughly the middle position
- Select Calibrate
- Sweep the pedal almost all the way up and almost all the way down. Normally, I would say go all the way up and all the way down, but since there appears to be an issue at the ends of the sweep, keeping it away from the ends in calibration would be a good idea
- Press a key to end calibration
- Press Done a few times to exit setup
- Read the settings back into the editor and save them. If you don't save the file and use it as a basis for all future changes, you'll lose the calibration settings.

If that doesn't work, we'll have to try a MIDI monitor to see what's going on.

Except for saving the settings in the editor, I've done the calibration as described. Tried resetting different parameters and re-testing, and it seems the problem lies in the Axe FX after updating the firmware. Did a full MIDI reset in the Axe FX, and it seems to fix the problem. Since I have two identical Mission pedals i tried both of them on different FX blocks, controlling different parameters, and they both give the same values on toe down, but different values for different blocks/parameters.
 
Top