MASTERMIND GT FIRMWARE 4.2.3 / EDITOR 4.2.0

Status
Not open for further replies.

touch33

Well-Known Member
Hi, Ron -
All previously reported issues with 4.1.0 and the FXII-XL+ are cured with 4.2.0.

But then you already knew that, didn’t you? Of course you did...
One Million Thanks 2 U - again!
Bruce
 

Lp59

Well-Known Member
Is there a way with 4.2.0 to send a #cc on Axe-FX midi channel from my iPad connect to the GT USB port, to recall a specific scene in the Axe-FX III?
 

rjmmusic

Administrator
Staff member
Hi, Ron -
All previously reported issues with 4.1.0 and the FXII-XL+ are cured with 4.2.0.

But then you already knew that, didn’t you? Of course you did...
One Million Thanks 2 U - again!
Bruce

Very happy to hear it's working!
 

rjmmusic

Administrator
Staff member
Is there a way with 4.2.0 to send a #cc on Axe-FX midi channel from my iPad connect to the GT USB port, to recall a specific scene in the Axe-FX III?

If you turn on MIDI Merge in the GT, it will forward all MIDI messages from the iPad to the Axe-Fx.
 

Lp59

Well-Known Member
If you turn on MIDI Merge in the GT, it will forward all MIDI messages from the iPad to the Axe-Fx.
Can I assign cc#34 in the Axe for scene control and play with the value to get the scene I want to recall? Will it not conflict with the sysex that are assigned in the GT OS? Can't test it right now, but will give it a try. Thanks a lot.
 

rjmmusic

Administrator
Staff member
Can I assign cc#34 in the Axe for scene control and play with the value to get the scene I want to recall? Will it not conflict with the sysex that are assigned in the GT OS? Can't test it right now, but will give it a try. Thanks a lot.

Don't assign anything in the Axe-Fx. CC#34 on the GT will automatically get translated to the correct sysex message for scene selection.
 

Lp59

Well-Known Member
Thanks Ron, it works. Marvelous! I have a preset that default to scene 1, I add in my iPad a cc#34 to get scene 4, the Axe goes to scene 4, but the GT stays on scene 1. Is there a solution for the GT to follow the scene in the Axe? I tried cc link in the IA's scene buttons with no success.

The goal is to have each song in my iPad send the correct PC, but also the right scene number, as I use the same preset in different songs with a different scene. The GT shows the selected Axe's scene on my Axe-Fx II. I hope this can be done in the III.

"Ignore Incoming CC" is turned off in Devices.
 
Last edited:

rjmmusic

Administrator
Staff member
Thanks Ron, it works. Marvelous! I have a preset that default to scene 1, I add in my iPad a cc#34 to get scene 4, the Axe goes to scene 4, but the GT stays on scene 1. Is there a solution for the GT to follow the scene in the Axe? I tried cc link in the IA's scene buttons with no success.

The goal is to have each song in my iPad send the correct PC, but also the right scene number, as I use the same preset in different songs with a different scene. The GT shows the selected Axe's scene on my Axe-Fx II. I hope this can be done in the III.

"Ignore Incoming CC" is turned off in Devices.

Make sure that Poll State is turned on in Devices.
 

Lp59

Well-Known Member
I must add that I have cc#34 for Scene Select in the Axe in Midi Setup. If I leave it to None, the scene does not change according to the CC# I send from my iPad.
 

rjmmusic

Administrator
Staff member
It is turned on, when I bypass a block in Axe~ Edit, it is well reflected on the GT. Scenes seem not to be updated.

Turn off grouping on your scene buttons - that's another thing that has to be turned off in order for the Axe-Fx to have control of the buttons.

And yes, if you're controlling the Axe-Fx with something other than the GT, you do need to use the Axe-Fx's MIDI setup to map CCs to functions.
 

Lp59

Well-Known Member
I did already ungrouped the scenes on preset 9 for testing, as you can see in my settings, no success. Should I nonetheless ungroup all presets to see if it works with preset 9?
 
Last edited:

Lp59

Well-Known Member
I ungrouped all scenes in all presets. The GT still shows default scene 4 on preset 9, and Axe follows the cc#34 from my iPad and is on scene 1.
I rebooted the Axe and it worked for 3 seconds, and then back to the same mystery.
The GT showed the default scene 4, then I guess the GT polled the scene infos from the Axe, then showed scene 1 that was sent from the iPad, (a big yes! Shortly followed be a sigh...) for 3 seconds and went back to default scene 4.
 

Attachments

  • 5.rjs
    1.9 MB · Views: 3
Last edited:

rjmmusic

Administrator
Staff member
When assigning scene buttons, make them have the same off value and on value. To select scene 4, have off:3 and on:3. If you right click on a button and select Assign CC > Axe-Fx III > Scene 4, it will set up an IA button with all the correct settings to select that scene so you don't have to remember all of the details.
 

rjmmusic

Administrator
Staff member
My last post is important to get scene names right, but I've just realized that it won't help your situation. I will look into it further. If it's reporting the wrong scene after a few seconds, I suspect this is an Axe-Fx bug. We'll see...
 

Lp59

Well-Known Member
My last post is important to get scene names right, but I've just realized that it won't help your situation. I will look into it further. If it's reporting the wrong scene after a few seconds, I suspect this is an Axe-Fx bug. We'll see...
This happened only when I reboot the Axe. And it does it only once, after that it continue to behave with the same error, right scene in the Axe, and wrong on the GT.
This was all working in the Axe-Fx II.
 
Status
Not open for further replies.
Top