1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MASTERMIND GT FIRMWARE / EDITOR 4.4.3

Discussion in 'GT General Discussion' started by rjmmusic, Nov 13, 2019.

Thread Status:
Not open for further replies.
  1. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,513
    Likes Received:
    1,180
    Firmware 4.4.1 is released, fixing a couple of reported bugs
     
    ANASON Records and AdrianG like this.
  2. Jop

    Jop
    Expand Collapse
    Well-Known Member

    Joined:
    Nov 17, 2016
    Messages:
    123
    Likes Received:
    18
    Thanks for the updates, I'll be installing after the current tour is over.

    I've requested this before, so sorry if that's annoying. Do you think it would be possible to add a search field under the presets tab in the editor? It would make navigating my many presets a lot easier.

    Cheers!
     
  3. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,513
    Likes Received:
    1,180
    I have so many feature requests for the editor, I really just need to do a major overhaul. Finding the time to do it is the trick...
     
    Jop likes this.
  4. ANASON Records

    ANASON Records
    Expand Collapse
    Member

    Joined:
    Nov 10, 2019
    Messages:
    7
    Likes Received:
    1
    i am new on boat but this is already such a great product. (both gt 16 and the editor software). not only this, customer service/product support of RJM is great also! So, i won't be one of those who complain if next update takes sometime :)
     
    Juraj likes this.
  5. Alexander

    Alexander
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 21, 2014
    Messages:
    477
    Likes Received:
    165
    "Bug":

    When I'm in Song Mode and then use the Preset Menu to select a preset, all is well: the main display shows the preset name.

    But when I don't use the Preset Menu, but instead select a preset by pressing a button that has been assigned to IA > System > Preset (...), the main display doesn't change to show the preset name. It still shows the previous Song title.

    Likewise, if the GT is in Song mode, and I switch presets on the Axe-Fx 3, the main display sometimes stays in "Song mode", and sometimes doesn't.
     
    #45 Alexander, Dec 13, 2019
    Last edited: Dec 13, 2019
  6. Alexander

    Alexander
    Expand Collapse
    Well-Known Member

    Joined:
    Oct 21, 2014
    Messages:
    477
    Likes Received:
    165
    Bug:

    When I launch the editor, mess around in the Song page only, and then select Write Changes, the changes are not being transferred.

    Only when selecting Write Settings, the changes in the Songs list are transferred.
     
  7. iaresee

    iaresee
    Expand Collapse
    Well-Known Member

    Joined:
    Sep 29, 2018
    Messages:
    105
    Likes Received:
    68
    This is amazing. Thank you, Ron!

    This is a very nice quality-of-life update all around.

    I have a minor ask for the editor: could you make it respond to the ESC key? It'd be great if pressing ESC was equivalent to pressing the "DONE" button with your mouse in switch edit dialogs.
     
  8. Paggzy

    Paggzy
    Expand Collapse
    Well-Known Member

    Joined:
    Jun 13, 2019
    Messages:
    63
    Likes Received:
    0
    Is there an LT version coming Ron??
     
  9. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,513
    Likes Received:
    1,180
    Currently, pressing Return does that for you, but I suppose I could add Esc as well.
     
    iaresee likes this.
  10. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,513
    Likes Received:
    1,180
    Yes, it should be out in a week or two.
     
  11. iaresee

    iaresee
    Expand Collapse
    Well-Known Member

    Joined:
    Sep 29, 2018
    Messages:
    105
    Likes Received:
    68
    vim user. my ESC habit is 30 years old at this point. :D
     
  12. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,513
    Likes Received:
    1,180
    I confess to having spent many years using vi, but it's a pretty rare occurrence these days

    :wq
     
    iaresee likes this.
  13. Toopy14

    Toopy14
    Expand Collapse
    Well-Known Member

    Joined:
    Nov 1, 2019
    Messages:
    45
    Likes Received:
    0
    I still use vi to write rules on my openHAB IoT controller running Linux on a PI-3. Love the command line! I learned CP/M in school.
     
    #53 Toopy14, Jan 10, 2020
    Last edited: Jan 10, 2020
  14. Mark Tan

    Mark Tan
    Expand Collapse
    New Member

    Joined:
    Apr 27, 2019
    Messages:
    1
    Likes Received:
    0
    Noob question here. Just updated to 4.4.1 but can't seem to find the "update Preset Name" button. How do I go about this?
     
  15. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,513
    Likes Received:
    1,180
    You should be able to edit a button, select Type and set it to Update Preset Name. I don't have a GT in front of me, but it definitely shows up as an option in the editor software v4.4.0.
     
  16. iaresee

    iaresee
    Expand Collapse
    Well-Known Member

    Joined:
    Sep 29, 2018
    Messages:
    105
    Likes Received:
    68
    Screen Shot 2020-01-18 at 1.46.58 PM.png

    @rjmmusic thank you for this button. I love this button.
     
    Jop and AdrianG like this.
  17. Lars Blomstrand

    Lars Blomstrand
    Expand Collapse
    Member

    Joined:
    Dec 9, 2016
    Messages:
    19
    Likes Received:
    1
    Bug:

    I think anyway....
    When I use the external switches to controlling my Ditto X4 I found a strange behavior.
    If I only use it to "Rec/Play/dub" as an IA, everything works without any problem but if i also use "Hold" to delete the last recording, then the "Rec/Play/Dub" still works but inverted. My Ditto doesn't engage until I release the button, not when it is pressed.
    Taking away the "Hold" function everything goes back to normal again.

    It would be nice to have the "clear last recording" back again, mistakes do happens when looping.... ;-)
     
    #57 Lars Blomstrand, Feb 12, 2020
    Last edited: Feb 12, 2020
  18. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,513
    Likes Received:
    1,180
    Firmware 4.4.2 now available, adds Source Audio Collider and Jackson Audio Broken Arrow and Bloom support, plus several bug fixes, listed at the top of this thread.
     
    AdrianG and Alexander like this.
  19. Dwelltone

    Dwelltone
    Expand Collapse
    Member

    Joined:
    May 25, 2019
    Messages:
    17
    Likes Received:
    2
    It may just be my computer but, I'm getting an error when trying to open the zip download file. It says "error 2 - no such file or directory." no matter where I try to open it. I have a MBP, could it be the download file?
     
  20. rjmmusic

    rjmmusic
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    6,513
    Likes Received:
    1,180
    Looks like the uploads were corrupted. Please try downloading again.
     
Thread Status:
Not open for further replies.

Share This Page